summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxwell Pray2024-02-16 11:47:57 -0800
committerMaxwell Pray2024-02-16 11:47:57 -0800
commit027ec20a6fb3396d202f666981b7a67b0ebc37a1 (patch)
tree39ff14e3f31cb208e096afa257c8cdf425bb7c82
downloadaur-vim-file-line-git.tar.gz
Initial commit at 9233f66.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD22
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3360bc4b2ab6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = vim-file-line-git
+ pkgdesc = Plugin for Vim to enable opening files with the file:line:column syntax
+ pkgver = r72.9233f66
+ pkgrel = 1
+ url = https://github.com/patnr/file-line
+ arch = any
+ license = GPL3
+ source = git+https://github.com/patnr/file-line.git
+ md5sums = SKIP
+
+pkgname = vim-file-line-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61afa9979f6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Maxwell Pray <synthead@gmail.com>
+
+_pkgname=file-line
+pkgname=vim-$_pkgname-git
+pkgver=r72.9233f66
+pkgrel=1
+pkgdesc="Plugin for Vim to enable opening files with the file:line:column syntax"
+arch=("any")
+url="https://github.com/patnr/file-line"
+license=("GPL3")
+source=("git+https://github.com/patnr/file-line.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -Dm 644 "$srcdir/$_pkgname/plugin/file_line.vim" "$pkgdir/usr/share/vim/vimfiles/plugin/file_line.vim"
+ install -Dm 644 "$srcdir/$_pkgname/README.md" "$pkgdir/usr/share/doc/README.md"
+}