summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-03-14 21:36:26 +0100
committerwillemw122023-03-14 21:36:26 +0100
commit079654cb9bdd77e8cdef4857449723cb0b718f00 (patch)
tree50e33e51d2692bdd6e92e4ac8b250ec863bd857c
parent2632b8fa7becc3d6b46a00cfb4056b9c71fa48a3 (diff)
downloadaur-vocal-git.tar.gz
Update to GTK4 and libadwaita rewrite
Update URL and description
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 26 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcaf0ddcbf83..45a4beee9299 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = vocal-git
- pkgdesc = Powerful, beautiful and simple podcast client for Pantheon
- pkgver = 2.4.2.r415.2cec1f1
+ pkgdesc = Powerful, beautiful, and simple podcast client for the modern free desktop
+ pkgver = 2.4.2.r73.gfeacd31
pkgrel = 1
- url = https://www.vocalproject.net
+ url = https://github.com/VocalPodcastProject/vocal
arch = x86_64
license = GPL3
- makedepends = cmake
makedepends = git
+ makedepends = meson
makedepends = vala
depends = clutter-gst
- depends = clutter-gtk
depends = granite
- depends = gst-libav
- depends = gst-plugins-good
- depends = gvfs
- depends = libnotify
- depends = webkit2gtk
+ depends = libadwaita
+ depends = libgee
+ depends = sqlite
+ depends = webkit2gtk-4.1
provides = vocal
conflicts = vocal
- source = vocal-git::git+https://github.com/needle-and-thread/vocal.git
+ source = vocal-git::git+https://github.com/VocalPodcastProject/vocal.git
sha256sums = SKIP
pkgname = vocal-git
diff --git a/PKGBUILD b/PKGBUILD
index fa870710ee4e..4d1d936862b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,36 +4,36 @@
# Contributor: jfperini <@jfperini>
pkgname=vocal-git
-pkgver=2.4.2.r415.2cec1f1
+pkgver=2.4.2.r73.gfeacd31
pkgrel=1
-pkgdesc="Powerful, beautiful and simple podcast client for Pantheon"
+pkgdesc='Powerful, beautiful, and simple podcast client for the modern free desktop'
arch=('x86_64')
-url="https://www.vocalproject.net"
+url='https://github.com/VocalPodcastProject/vocal'
license=('GPL3')
-depends=('clutter-gst' 'clutter-gtk' 'granite' 'gst-libav' 'gst-plugins-good' 'gvfs' 'libnotify' 'webkit2gtk')
-makedepends=('cmake' 'git' 'vala')
+depends=('clutter-gst' 'granite' 'libadwaita' 'libgee' 'sqlite' 'webkit2gtk-4.1') # 'libsecret'
+makedepends=('git' 'meson' 'vala')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=($pkgname::git+https://github.com/needle-and-thread/vocal.git)
+source=($pkgname::git+$url.git)
sha256sums=('SKIP')
pkgver() {
- cd $pkgname
- #git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
- printf "%s.r%s.%s" "$(git tag --sort=-version:refname | head -1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git -C $pkgname describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- # Patch: fix build with granite 6 by disabling the About dialog (https://github.com/needle-and-thread/vocal/issues/483)
- sed -i 's/controller.app.show_about (this);//' $pkgname/src/MainWindow.vala
+build() {
+ meson setup --buildtype=plain --prefix=/usr $pkgname build
+
+ #meson -C build compile
+ ninja -C build
}
-build() {
- cmake -B build -S $pkgname -DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_PREFIX=/usr -Wno-dev # -DGSETTINGS_COMPILE=0 -DGSETTINGS_LOCALINSTALL=1
- make -C build
+check() {
+ #meson -C build test
+ ninja -C build test
}
package() {
- make -C build DESTDIR="$pkgdir/" install
+ #meson -C build install --destdir="$pkgdir"
+ DESTDIR="$pkgdir" ninja -C build install
}
-