summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMansour Behabadi2022-07-08 01:06:18 +1000
committerMansour Behabadi2022-07-08 01:06:18 +1000
commit715df57d958a1bf11508dfb72940ff8a6505d5d8 (patch)
treeff8662baf32efdb745b7d8cc722db0e70afb741d
parentc26166f019764b42f9d5ea55c794d9d4d447ba4b (diff)
downloadaur-whsniff-git.tar.gz
Move to whsniff-git
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
2 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71b2ba6c2605..c645ff3ad180 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
-pkgbase = whsniff
+pkgbase = whsniff-git
pkgdesc = A command line utility that interfaces TI CC2531 USB dongle with Wireshark for capturing and displaying IEEE 802.15.4 traffic at 2.4 GHz.
- pkgver = 1.1.r10.920e107
- pkgrel = 2
- url = https://github.com/homewsn/whsniff.git
+ pkgver = 1.1.r38.4894032
+ pkgrel = 1
+ url = https://github.com/homewsn/whsniff
arch = x86_64
license = GPL
makedepends = sed
depends = libusb
- source = whsniff::git+https://github.com/homewsn/whsniff.git
+ provides = whsniff=1.1.r38.4894032
+ conflicts = whsniff
+ replaces = whsniff<=1.1.r18
+ source = whsniff-git::git+https://github.com/homewsn/whsniff.git
sha256sums = SKIP
-pkgname = whsniff
-
+pkgname = whsniff-git
diff --git a/PKGBUILD b/PKGBUILD
index 347cd804f3da..69ee0753d8d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
-# Maintainer: Alex Mekkering <amekkering at gmail dot com>
+# Maintainer: Mansour Behabadi <mansour@oxplot.com>
+# Contributor: Alex Mekkering <amekkering at gmail dot com>
-pkgname=whsniff
-_pkgver=1.1
-pkgver=1.1.r10.920e107
-pkgrel=2
+pkgname=whsniff-git
+pkgver=1.1.r38.4894032
+pkgrel=1
pkgdesc="A command line utility that interfaces TI CC2531 USB dongle with Wireshark for capturing and displaying IEEE 802.15.4 traffic at 2.4 GHz."
arch=('x86_64')
-url='https://github.com/homewsn/whsniff.git'
+url='https://github.com/homewsn/whsniff'
license=('GPL')
depends=('libusb')
+provides=("whsniff=${pkgver}")
+conflicts=('whsniff')
+replaces=('whsniff<=1.1.r18')
makedepends=('sed')
source=( "${pkgname}::git+https://github.com/homewsn/whsniff.git" )
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
- printf "${_pkgver}.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "1.1.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {