summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGu1ll0me2020-06-04 11:48:22 -0400
committerGu1ll0me2020-06-04 11:48:22 -0400
commit4e917f912a7a3ab9bdd7b18089f46ef3172a81e3 (patch)
tree6d6024f4fb833b97452398d2c8c5cc7f7efc94ce
parent5d3f7f9e8925df15e02a62febac807527461a3f8 (diff)
downloadaur-xow.tar.gz
Fix systemd service
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec2d46dcb405..49a3d384ba35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,8 @@
pkgbase = xow
pkgdesc = Linux driver for the Xbox One wireless dongle
pkgver = 0.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/medusalix/xow
- install = xow.install
arch = x86_64
license = GPL2
depends = libusb
diff --git a/PKGBUILD b/PKGBUILD
index a96dc4277d8a..4fa7986ea074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,30 @@
pkgname=xow
pkgver=0.5
-pkgrel=1
+pkgrel=2
pkgdesc='Linux driver for the Xbox One wireless dongle'
arch=('x86_64')
url='https://github.com/medusalix/xow'
license=('GPL2')
depends=('libusb' 'cabextract')
conflicts=('xow-git')
-install=$pkgname.install
source=("$pkgname-$pkgver.tar.gz::https://github.com/medusalix/xow/archive/v$pkgver.tar.gz")
md5sums=('37193261c48ec5d3e703f5a045e7427f')
build() {
cd "$pkgname-$pkgver"
- make BUILD=RELEASE
+ make PREFIX=/usr BUILD=RELEASE
+ make PREFIX=/usr BUILD=RELEASE xow.service
}
package() {
cd "$pkgname-$pkgver"
- make DESTDIR=$pkgdir/usr PREFIX="" install
+ make PREFIX=/usr DESTDIR=$pkgdir/ SYSDDIR=/usr/lib/systemd/system install
+
+ echo ""
+ echo "To enable and start the service:"
+ echo -e "\e[33msystemctl enable --now xow.service"
+ echo ""
+ echo -e "\e[33mA reboot might be required for xow to work correctly."
+ echo ""
}