summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmitriy Morozov2015-06-19 10:34:07 -0700
committerDmitriy Morozov2015-06-19 10:34:07 -0700
commit335782ce4232f17810e4fc24f1f14e8824168615 (patch)
treea6bd72aafb7acf5d09d6848b40fdff2a9432294e
parentf1cf83419c3134a55d579f11e37b452b7d519f0c (diff)
downloadaur-335782ce4232f17810e4fc24f1f14e8824168615.tar.gz
Fixed compilation issue related to lua versions (use lua52)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--config.patch21
3 files changed, 13 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ead9f7aa75b9..8662216a4f2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = ipe
pkgdesc = The extensible drawing editor
pkgver = 7.1.7
- pkgrel = 2
+ pkgrel = 3
url = http://tclab.kaist.ac.kr/ipe/
arch = i686
arch = x86_64
license = GPL
- depends = lua
+ depends = lua52
depends = qt4
depends = freetype2
depends = zlib
@@ -20,7 +20,7 @@ pkgbase = ipe
md5sums = 8c31313ec839fb7958b4a627634c907e
md5sums = 3bc8dc576ee3acced2ff3c6ea6a01319
md5sums = 694f0d5402655901be385647e5d8d6e3
- md5sums = af3db2930ff57decb63cd322a845b025
+ md5sums = c163912a81062e0d9b7ffcfbdfdce7e0
pkgname = ipe
diff --git a/PKGBUILD b/PKGBUILD
index 982c66991ac6..9769423c0f88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,10 +4,10 @@ pkgname=ipe
_sfproject=ipe7
_dirver=7.1
pkgver=7.1.7
-pkgrel=2
+pkgrel=3
pkgdesc="The extensible drawing editor"
url="http://tclab.kaist.ac.kr/ipe/"
-depends=('lua' 'qt4' 'freetype2' 'zlib' 'poppler' 'python2')
+depends=('lua52' 'qt4' 'freetype2' 'zlib' 'poppler' 'python2')
arch=('i686' 'x86_64')
license=("GPL")
conflicts=('ipe')
@@ -20,7 +20,7 @@ source=("http://downloads.sourceforge.net/project/$_sfproject/$pkgname/$_dirver/
md5sums=('8c31313ec839fb7958b4a627634c907e'
'3bc8dc576ee3acced2ff3c6ea6a01319'
'694f0d5402655901be385647e5d8d6e3'
- 'af3db2930ff57decb63cd322a845b025')
+ 'c163912a81062e0d9b7ffcfbdfdce7e0')
prepare() {
cd "$srcdir/$pkgname-$pkgver/src"
diff --git a/config.patch b/config.patch
index 0c9dad699aa9..2bc046560e77 100644
--- a/config.patch
+++ b/config.patch
@@ -1,31 +1,24 @@
---- config.mak 2014-05-07 00:28:31.000000000 -0700
-+++ ../../../ipe-7.1.5/src/config.mak 2014-05-07 07:08:11.675366079 -0700
-@@ -31,7 +31,7 @@
+--- config.mak 2015-02-23 05:02:13.000000000 -0800
++++ /home/users/morozov/config.mak 2015-06-19 10:31:32.271140419 -0700
+@@ -34,7 +34,7 @@
#
# The name of the Lua package (it could be "lua", "lua52", or "lua5.2")
#
-LUA_PACKAGE ?= lua5.2
-+LUA_PACKAGE ?= lua
++LUA_PACKAGE ?= lua52
#
ZLIB_CFLAGS ?=
ZLIB_LIBS ?= -lz
-@@ -57,7 +57,7 @@
+@@ -62,7 +62,7 @@
# If you have different Qt versions installed, you may have to change
- # this to "moc-qt4" if the default is Qt3's "moc".
+ # this to "moc-qt4"
#
-MOC ?= moc
+MOC ?= moc-qt4
#
else
#
-@@ -76,13 +76,13 @@
- -I/usr/X11/include/libpng12
- CAIRO_LIBS ?= -L/usr/X11/lib -lcairo
- LUA_CFLAGS ?= -I/usr/local/include
--LUA_LIBS ?= -L/usr/local/lib -llua52 -lm
-+LUA_LIBS ?= -L/usr/local/lib -llua -lm
- QT_CFLAGS ?= -I/Library/Frameworks/QtCore.framework/Versions/4/Headers \
- -I/Library/Frameworks/QtGui.framework/Versions/4/Headers
+@@ -89,7 +89,7 @@
QT_LIBS ?= -F/Library/Frameworks -L/Library/Frameworks \
-framework QtCore -framework ApplicationServices \
-framework QtGui -framework AppKit -framework Cocoa -lz -lm