summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Szczuczko2019-05-15 06:44:33 -0600
committerAlex Szczuczko2019-05-15 06:46:40 -0600
commit81798a425867cc7c38b9c71e076c3709e1ebb4e0 (patch)
tree873cd7587f3dbabda023cefaab759f169b295675
parente7f138bf480ef2c12543113054dfde8ef3177bdb (diff)
downloadaur-81798a425867cc7c38b9c71e076c3709e1ebb4e0.tar.gz
Fix build issues (Credit to Lekensteyn)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
-rw-r--r--cmake.patch24
-rw-r--r--cudd-waitstatus.patch17
4 files changed, 69 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2fd0fd7b40e..879ad16e34bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Mar 2 19:29:03 UTC 2016
+# Wed May 15 12:46:24 UTC 2019
pkgbase = nusmv
pkgdesc = A new symbolic model checker
pkgver = 2.6.0
- pkgrel = 2
+ pkgrel = 3
url = http://nusmv.fbk.eu/index.html
arch = i686
arch = x86_64
@@ -15,7 +15,11 @@ pkgbase = nusmv
depends = libxml2
optdepends = perl: for scripts in /usr/share/nusmv/contrib/
source = http://nusmv.fbk.eu/distrib/NuSMV-2.6.0.tar.gz
+ source = cmake.patch
+ source = cudd-waitstatus.patch
sha256sums = dba953ed6e69965a68cd4992f9cdac6c449a3d15bf60d200f704d3a02e4bbcbb
+ sha256sums = 7bc96f6a87b2c8a8b931d4ce17a5d49a5decf468b612165d4385753906fc1103
+ sha256sums = 0abb360d7856809461f75d4e4ba7ba34bc62b40efed256acbca67b0757d66e77
pkgname = nusmv
diff --git a/PKGBUILD b/PKGBUILD
index 454b14dd9612..cdd321fef4a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Alex Szczuczko <alex@szc.ca>
# Contributor: Marcelo Alaniz <malaniz@code4life.com.ar>
+# Contributor: Peter Wu <peter@lekensteyn.nl>
pkgname=nusmv
_pkgname=NuSMV
pkgver=2.6.0
-pkgrel=2
+pkgrel=3
pkgdesc="A new symbolic model checker"
arch=('i686' 'x86_64')
url="http://nusmv.fbk.eu/index.html"
@@ -12,8 +13,26 @@ license=('LGPL2.1')
depends=('libxml2')
makedepends=('cmake' 'python2' 'ghostscript' 'texlive-latexextra')
optdepends=('perl: for scripts in /usr/share/nusmv/contrib/')
-source=("http://nusmv.fbk.eu/distrib/${_pkgname}-${pkgver}.tar.gz")
-sha256sums=('dba953ed6e69965a68cd4992f9cdac6c449a3d15bf60d200f704d3a02e4bbcbb')
+source=("http://nusmv.fbk.eu/distrib/${_pkgname}-${pkgver}.tar.gz"
+ "cmake.patch"
+ "cudd-waitstatus.patch")
+sha256sums=('dba953ed6e69965a68cd4992f9cdac6c449a3d15bf60d200f704d3a02e4bbcbb'
+ '7bc96f6a87b2c8a8b931d4ce17a5d49a5decf468b612165d4385753906fc1103'
+ '0abb360d7856809461f75d4e4ba7ba34bc62b40efed256acbca67b0757d66e77')
+
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+
+ # Have to expose HAVE_UNISTD_H and others to avoid implicit func warnings.
+ patch -Np1 -i "${srcdir}/cmake.patch"
+
+ # "union wait" (BSD compat?) was removed in cudd 2.5.0
+ patch -Np1 -i "${srcdir}/cudd-waitstatus.patch"
+
+ # Fix "error: expected unqualified-id before user-defined string literal"
+ sed 's/extern "C"void/extern "C" void/' MiniSat/MiniSat_v*.patch -i
+}
build() {
cd "$srcdir/$_pkgname-$pkgver/$_pkgname"
diff --git a/cmake.patch b/cmake.patch
new file mode 100644
index 000000000000..ee4329d25759
--- /dev/null
+++ b/cmake.patch
@@ -0,0 +1,24 @@
+diff --git a/NuSMV/CMakeLists.txt b/NuSMV/CMakeLists.txt
+index ae559c4..e9d5655 100644
+--- a/NuSMV/CMakeLists.txt
++++ b/NuSMV/CMakeLists.txt
+@@ -64,6 +64,10 @@ if(PREFER_STATIC_LIBRARIES)
+ list(INSERT CMAKE_FIND_LIBRARY_SUFFIXES 0 ${CMAKE_STATIC_LIBRARY_SUFFIX})
+ endif()
+
++# Expose nusmv-config.h to cudd for some feature checks.
++add_definitions(-DHAVE_CONFIG_H)
++include_directories("${CMAKE_BINARY_DIR}")
++
+ add_subdirectory(${CUDD_SOURCE_DIR} ${CUDD_BUILD_DIR})
+
+ if(ENABLE_MINISAT)
+@@ -328,8 +332,6 @@ set(nusmv_core_libs # the order is relevant here
+ nusmv_write_config_h(nusmv-config.h)
+ install(FILES "${PROJECT_BINARY_DIR}/nusmv-config.h" DESTINATION include)
+
+-add_definitions(-DHAVE_CONFIG_H)
+-
+
+ # ----------------------------------------------------------------------
+ # source code include dirs
diff --git a/cudd-waitstatus.patch b/cudd-waitstatus.patch
new file mode 100644
index 000000000000..6abe52dc0d87
--- /dev/null
+++ b/cudd-waitstatus.patch
@@ -0,0 +1,17 @@
+diff --git a/cudd-2.4.1.1/util/pipefork.c b/cudd-2.4.1.1/util/pipefork.c
+index 1d58bac..cfd5c12 100644
+--- a/cudd-2.4.1.1/util/pipefork.c
++++ b/cudd-2.4.1.1/util/pipefork.c
+@@ -39,12 +39,7 @@ int util_pipefork(char **argv, /* normal argv argument list */
+ int forkpid, waitPid;
+ int topipe[2], frompipe[2];
+ char buffer[1024];
+-
+-#if (defined __hpux) || (defined __osf__) || (defined _IBMR2) || (defined __SVR4) || (defined __CYGWIN32__) || (defined __MINGW32__)
+ int status;
+-#else
+- union wait status;
+-#endif
+
+ /* create the PIPES...
+ * fildes[0] for reading from command