summarylogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaichi Shinozaki2015-06-09 18:20:44 +0900
committerDaichi Shinozaki2015-06-09 18:20:44 +0900
commit7a38f8ab8561d63adc6d19f0934388395a63b9bc (patch)
tree48a13aa37ede0866e1cc9aaff8379362b3078016 /Makefile
downloadaur-mod_diary-git.tar.gz
Initial import
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..312b5a7f4692
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,20 @@
+builddir = .
+
+top_dir = /usr/lib/httpd
+
+top_srcdir = ${top_dir}
+top_builddir = ${top_dir}
+
+include ${top_builddir}/build/special.mk
+
+APXS = apxs
+APACHECTL = apachectl
+CFLAGS += -I/usr/include/ClearSilver
+
+all: local-shared-build diary-mkindex
+
+diary-mkindex:
+ $(CC) $(CFLAGS) diary-mkindex.c -lmarkdown -lneo_utl -lneo_cs -o $@
+
+clean:
+ -rm -f *.o *.lo *.slo *.la diary-mkindex