summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortetov2019-02-11 23:58:16 +0100
committertetov2019-02-11 23:58:16 +0100
commit8c4e1f21da5a3beb677db9bb66cb46f50ca00b32 (patch)
treec12eebb85490efa6c3c552f75907be418ca7414c /PKGBUILD
parentce93f40a43638d96a79a2a0274dcb92192c114a8 (diff)
downloadaur-arcus-beta-git.tar.gz
upgpkg: arcus-beta-git r367.cfb4921-1
upgpkg: cura-beta-git r18273.14c361a29-1 upgpkg: curaengine-beta-git r6631.d9a326d2-1 upgpkg: uranium-beta-git r7389.2b2ea40b-1 pkgver() added, consistency, removed previous aur name from conflicts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1abe91373f06..12a7c9dd05f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Grey Christoforo <first name [at] last name [dot] net>
pkgname=arcus-beta-git
-pkgver=4.0
+pkgver=r367.cfb4921
pkgrel=1
pkgdesc="Communication library between internal components for Ultimaker software"
arch=('x86_64')
@@ -13,10 +13,15 @@ license=('LGPL3')
depends=('python' 'protobuf' 'python-sip')
makedepends=('cmake' 'git' 'sip')
provides=('arcus' 'libarcus')
-conflicts=('arcus' 'libarcus' 'arcus-beta')
-source=("git+${url}#branch=${pkgver}")
+conflicts=('arcus' 'libarcus')
+source=("git+${url}#branch=4.0")
md5sums=('SKIP')
+pkgver(){
+ cd libArcus
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd libArcus
mkdir -p build