summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorabxxbo2022-03-17 21:31:21 -0500
committerabxxbo2022-03-17 21:31:21 -0500
commit93568b14227028bee0daca33a30260bf4df34873 (patch)
tree9af2f6789b1c5449e1f58ab54a8ee691867a9d95 /PKGBUILD
downloadaur-awm-git.tar.gz
Initial push.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad643670c868
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: abxxbo <devavcado@gmail.com
+pkgname=awm-git
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="A floating window manager written with XCB."
+arch=(x86_64 x86)
+url="https://github.com/abxxbo/awm.git"
+license=('GPL')
+groups=()
+depends=()
+makedepends=(libxcb xcb-util xcb-util-keysyms xcb-util-wm)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd awm
+ make
+}
+
+package() {
+ cd awm
+ make DESTDIR="$pkgdir/" install
+}