summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2021-08-20 21:28:56 +0200
committerFabioLolix2021-08-20 21:28:56 +0200
commit958fc42b0423c3d2d1a844c7c4f621cf53899585 (patch)
treed3a6a4712569121884763406d4a2ce0f221b6f46 /PKGBUILD
parent5597847d571838af481e10d3abb609a1c195c6b3 (diff)
downloadaur-aws-iam-authenticator-git.tar.gz
revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c6cc478ba20..213639433218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,17 @@
+# Maintainer:
+# Contributor: FabioLolix
+# Contributor: micwoj92
# Contributor: Chris Snell <chris.snell@gmail.com>
pkgname=aws-iam-authenticator-git
_pkgname=aws-iam-authenticator
-pkgver=v0.5.3.r16.g375e2c90
+pkgver=0.5.3.r16.g375e2c90
pkgrel=1
pkgdesc='A tool to use AWS IAM credentials to authenticate to a Kubernetes cluster'
arch=('x86_64' 'aarch64')
url='https://github.com/kubernetes-sigs/aws-iam-authenticator'
license=('Apache')
-makedepends=('go')
+makedepends=('go' git)
conflicts=('aws-iam-authenticator')
provides=('aws-iam-authenticator')
source=('git+https://github.com/kubernetes-sigs/aws-iam-authenticator.git')
@@ -16,17 +19,18 @@ sha512sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- ( set -o pipefail
- git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "$srcdir/$_pkgname"
+
go build \
- --trimpath \
- --ldflags "-X main.version=$pkgver" \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\"" \
./cmd/aws-iam-authenticator
}