summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2019-12-16 22:10:18 -0500
committerGuillaume Horel2019-12-16 22:10:18 -0500
commit3d0965d4d3a0ea8a72170abe40d78d63b4337e1e (patch)
treebab87c0f9a525f74d25a45b0746b66e1fc1ab603 /PKGBUILD
parent51b57e2299194df77e36c75a331c7ccd35bf5917 (diff)
downloadaur-bcunit-git.tar.gz
version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f1224376ec6..4cc627f01c27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bcunit-git
_pkgname=bcunit
-pkgver=3.0.2.r11.g966505d
+pkgver=3.0.2+12+g3c720fb
pkgrel=1
pkgdesc="A fork of CUnit, a C unit testing framework"
arch=('x86_64')
@@ -10,24 +10,24 @@ url="http://www.linphone.org/"
license=('GPL')
depends=()
makedepends=('cmake' 'git')
-provides=('bcunit')
+provides=('bcunit=$pkgver')
conflicts=('bcunit')
source=("git+https://gitlab.linphone.org/BC/public/bcunit.git")
sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/\1/; s/-/+/g'
}
build() {
cd "${srcdir}"
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_LIBDIR="/usr/lib" \
- -DCMAKE_INSTALL_PREFIX="/usr" \
- -DENABLE_STATIC=NO \
- "../$_pkgname"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DENABLE_STATIC=NO \
+ "../$_pkgname"
make
}