summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2024-03-07 16:30:49 -0500
committerPatrick Northon2024-03-07 16:30:49 -0500
commit707e3689f080899e9d7cf09bc98ad9014a69bcb2 (patch)
treea78172c01164e0a126b64656b6d1e22a3aa663b4 /PKGBUILD
parentdd6218850355de590f17b3c2464104d3d8b062e8 (diff)
downloadaur-beakerlib.tar.gz
Update version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fdd9a43c609..77b527dcb0ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
pkgname=beakerlib
-pkgver=1.29.3
-pkgrel=2
+pkgver=1.30
+pkgrel=1
pkgdesc="Shell-level integration testing library, providing convenience functions which simplify writing, running and analysis of integration and blackbox tests."
arch=('i686' 'x86_64')
url="https://github.com/beakerlib/beakerlib"
@@ -10,16 +10,24 @@ license=('GPL2')
depends=()
makedepends=('perl')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/beakerlib/beakerlib/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('f792b86bac8be1a4593dd096c32c1a061102c802c6f5760259a5753b13f6caa1')
+sha256sums=('bd06fc61b32d9caf4324587706a8363e37e771355da8297d0c5ba0023ae31098')
_srcdir="${pkgname}-${pkgver}"
+prepare() {
+ cd "${_srcdir}"
+ sed -i 's/install: build/install:/' 'Makefile' 'src/Makefile'
+}
+
build() {
cd "${_srcdir}"
- make
+ make build
}
package() {
cd "${_srcdir}"
- make DD="${pkgdir}" install
+ make DESTDIR="${pkgdir}/usr" install
+
+ mkdir -p "${pkgdir}/usr/lib/tmpfiles.d"
+ install -m0644 "dist/${pkgname}-tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
}