summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntoine Viallon2019-02-26 23:39:32 +0000
committerAntoine Viallon2019-02-26 23:39:32 +0000
commit2a18b4c2220ea0a569bcfe922e6d867ba0a49ce4 (patch)
tree7faa3fcbae652eeb95a5d68e62d8cfe2f4e5228d /PKGBUILD
parent5bdd69f657cc716e4cd55a45ccb33b76e1147ec8 (diff)
downloadaur-binfmt-support.tar.gz
Added build dependencies and a deprecation warning to the package build, plus a confirmation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71be0a0df84c..f23533259c90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,35 @@
pkgname=binfmt-support
pkgver=2.2.0
_pkgver=2.2.0 # For use with RC releases, to replace the - with _
-pkgrel=1
+pkgrel=2
pkgdesc="Arbitraty executable file format kernel extension"
arch=('i686' 'x86_64')
url="https://git.savannah.gnu.org/cgit/binfmt-support.git/"
license=('GPL')
depends=('autoconf' 'automake')
-makedepends=('make' 'gcc')
+makedepends=('make' 'gcc' 'git' 'libpipeline')
source=("https://git.savannah.gnu.org/cgit/binfmt-support.git/snapshot/$pkgname-$_pkgver.tar.gz")
sha512sums=('b35238fa96f7e3201f7c9a70172ecd2c6b0be66e4735ff96c17ae2167f670a67c856d0fc1b0d50bf3c14f4a35c5e9927a848814791ea9be928dff82426cb0da4')
prepare() {
- set -e
- cd "${srcdir}/$pkgname-$_pkgver"
- ./bootstrap
+ echo -e '\033[0;31mWARNING : \033[1;33mThis package is deprecated, please use systemd-binfmt instead.\033[0m'
+ read -p "Do you really want to install it anyway ? " yn
+ case $yn in
+ [Nn]* ) exit;;
+ esac
+ set -e
+ cd "${srcdir}/$pkgname-$_pkgver"
+ ./bootstrap
}
build() {
cd "${srcdir}/$pkgname-$_pkgver"
./configure --prefix=/usr \
- --libexecdir=/usr/lib \
- --sbindir=/usr/bin \
- --sysconfdir=/etc \
- --disable-upstart
+ --libexecdir=/usr/lib \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --disable-upstart
make
}