aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormarnout2019-01-19 16:11:20 +0100
committermarnout2019-01-19 16:11:20 +0100
commitb3df418e86d63248cd3dc8150eb2dba0cd417c89 (patch)
tree4ff42cbe7340b0096ebc05916daeb8c081209ff5 /PKGBUILD
parent11a2682ce75ce5c05d0f9ee58eea111b4d56ba66 (diff)
downloadaur-brother-dcpj140w.tar.gz
rm makedep from PKGBUILD and add README
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 11 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d0bd1f97833..6af2a99619b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Contributor: Alessio Bianchi <venator85@gmail.com>
# Contributor: Jacek Roszkowski <j.roszk@gmail.com>
# Contributor: Javier Cordero <jneight@gmail.com>
-# Contributor: Vieux Grognon <vieux@grognon.net>
-# Maintainer: Vieux Grognon <vieux@grognon.net>
+# Contributor: M. Arnout <marnout at free.fr>
+# Maintainer: M. Arnout <marnout at free.fr>
pkgname=brother-dcpj140w
pkgver=1.1.3
@@ -11,7 +11,6 @@ pkgdesc="Driver for the Brother DCP-j140w wifi multifuncional printer"
url="http://solutions.brother.com/linux/en_us/index.html"
license=('custom:brother')
depends=('a2ps' 'cups')
-makedepends=('rpmextract')
install="brother-dcpj140w.install"
arch=('i686' 'x86_64')
@@ -20,24 +19,24 @@ md5sums=('69229583e5d43d82e5655f74729c05ba'
'fa2d50677492bfc83e27184f316061c3')
source=(
- "fix_lp.patch" \
- "http://www.brother.com/pub/bsc/linux/dlf/dcpj140wlpr-$pkgver-6.i386.rpm" \
+ "fix_lp.patch" \
+ "http://www.brother.com/pub/bsc/linux/dlf/dcpj140wlpr-$pkgver-6.i386.rpm" \
"http://www.brother.com/pub/bsc/linux/dlf/dcpj140wcupswrapper-$pkgver-6.i386.rpm"
)
build() {
- cd "$srcdir"
- patch -Np0 < fix_lp.patch
+ cd "$srcdir"
+ patch -Np0 < fix_lp.patch
}
post_install() {
- /opt/brother/Printers/dcpj140w/cupswrapper/cupswrapperdcpj140w
+ /opt/brother/Printers/dcpj140w/cupswrapper/cupswrapperdcpj140w
}
package()
{
- install -d $pkgdir/usr/bin
- install -d $pkgdir/var/spool/lpd
- install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj140w "$pkgdir"/usr/bin/
- cp -R $srcdir/opt $pkgdir/opt
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/var/spool/lpd
+ install -Dm755 "$srcdir"/usr/bin/brprintconf_dcpj140w "$pkgdir"/usr/bin/
+ cp -R $srcdir/opt $pkgdir/opt
}