summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndre Schröder2020-10-27 22:05:19 +0100
committerAndre Schröder2020-10-27 22:05:19 +0100
commit068a05ce7f51babd1db2fbf5f00608ba9129f9b9 (patch)
tree1275a01401c70af3038b8d2372ddf0ffc5794f8d /PKGBUILD
parent9b0158fcd851b2d1c8620f11a8d06b1ecaa650da (diff)
downloadaur-cgrep-clang-git.tar.gz
Fix cgrep for clang 10
See https://www.archlinux.org/todo/llvm-10/: > All of clang's C++ API is now shipped as `libclang-cpp.so` instead of > the numerous component libraries we had before. This change will > require patching in most packages to use the new library name. Look > for upstream commits that support the new library; if that fails, > Fedora and/or Gentoo should have patches for this. upgpkg: cgrep-clang-git r154.f7e9ac8-1 upgpkg: cgrep-clang 1.1-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 798a099216af..258a5eff1fa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,21 @@
_name=cgrep-clang
pkgname=$_name-git
-pkgver=r143.a6c42a8
+pkgver=r154.f7e9ac8
_mainfolder=$_name
-pkgrel=2
+pkgrel=1
pkgdesc='grep for C/C++ source files'
arch=(any)
url=https://github.com/bloodstalker/cgrep
license=(GPL3)
depends=(llvm clang)
makedepends=(git)
-source=($_name::git+$url git+https://github.com/bloodstalker/cfe-extra)
+source=($_name::git+$url
+ git+https://github.com/bloodstalker/cfe-extra
+ adjust-libclang-lib-names.patch)
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'c726ccfdc45f9ad434647cfcab95ac536700ab87978f05f3a341a555642eb8c4')
conflicts=($_name)
provides=($_name)
@@ -40,6 +43,9 @@ prepare() {
package() {
cd "$srcdir/$_mainfolder"
+ # see https://www.archlinux.org/todo/llvm-10/
+ patch -p1 -i "$srcdir/adjust-libclang-lib-names.patch"
+
make
# `make install` isn't provided, so we have to manually copy the files