summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAzat Khuzhin2023-12-04 20:44:41 +0100
committerAzat Khuzhin2023-12-04 20:53:59 +0100
commitba4403e0ae759782c4eccec2c6e9783d398ab143 (patch)
tree158e61398c1b337da128a3b8bbb88af99c23be1d /PKGBUILD
downloadaur-chdig-latest-bin.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71b946231dfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# shellcheck disable=SC2034,SC2154
+# - SC2034 - appears unused.
+# - SC2154 - pkgdir is referenced but not assigned.
+
+# Maintainer: Azat Khuzhin <a3at.mail@gmail.com>
+pkgname=chdig-latest-bin
+pkgver=0.4.0.32.g0d80c8c.1
+pkgrel=1
+pkgdesc="Dig into ClickHouse with TUI interface (compiled binaries for upstream)"
+arch=('x86_64')
+conflicts=("chdig")
+provides=("chdig")
+url="https://github.com/azat/chdig"
+license=('MIT')
+source=(
+ "https://github.com/azat/chdig/releases/download/latest/chdig-latest-x86_64.pkg.tar.zst"
+)
+sha256sums=(
+ 'SKIP'
+)
+
+# Rewrite version from latest to the real one
+pkgver() {
+ tar -xf chdig-latest-x86_64.pkg.tar.zst -O .PKGINFO | awk '/pkgver/ { print $NF }' | sed -e 's/-/./g'
+}
+
+package() {
+ tar -C "$pkgdir" -xvf chdig-latest-x86_64.pkg.tar.zst
+ rm -f "$pkgdir/.PKGINFO"
+ rm -f "$pkgdir/.MTREE"
+}
+# vim set: ts=4 sw=4 et