summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:08:27 +0100
committerSteven Honeyman2015-06-09 19:08:27 +0100
commitd26b99d2d650cd7f643b48b7454d84959c4466b5 (patch)
tree6c96ec2eadb8c33d5e709bbf1f7ce639f15aaf69 /PKGBUILD
downloadaur-concalc.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d8882b32f0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+
+pkgname=concalc
+pkgver=0.9.3
+pkgrel=1
+pkgdesc="Concalc is a calculator for the Linux console"
+arch=('i686' 'x86_64')
+url="http://extcalc-linux.sourceforge.net/concalcdescr.html"
+license=('GPL')
+source=(http://downloads.sourceforge.net/extcalc-linux/$pkgname-$pkgver.tar.gz)
+md5sums=('802f7753ef3f0141c5607b52d7ceb4bd')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver/src"
+ g++ -Os -s concalc.cpp global.cpp -o concalc
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 src/concalc $pkgdir/usr/bin/concalc
+ install -Dm644 man/concalc.1.gz $pkgdir/usr/share/man/man1/concalc.1.gz
+}