summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgilcu32022-09-20 17:29:16 +0200
committergilcu32022-09-20 17:29:16 +0200
commit1e6427bf956da5aa0590f1e9870e9b3deb8e00af (patch)
tree73ad9bede7d771ede686db483e5981bc70bd1838 /PKGBUILD
downloadaur-conf2struct-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4305bf211326
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: gilcu3 <gilcu3 at gmail dot com>
+
+_pkgname=conf2struct
+pkgname=$_pkgname-git
+pkgver=1.5.r0.g6bc9eed
+pkgrel=1
+pkgdesc="conf2struct takes a configuration file that describes a configuration file in the libconfig format, and generates a C parser that will read a configuration file directly into a C structure"
+arch=('i686' 'x86_64')
+url='https://www.rutschle.net/tech/conf2struct/README.html'
+license=('GPL2')
+depends=('libconfig' 'perl' 'perl-conf-libconfig')
+makedepends=('git' 'libconfig' 'perl-conf-libconfig' 'pcre2' 'perl')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=($pkgname::"git+https://github.com/yrutschle/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+}
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ # Executables
+ install -Dm755 $srcdir/$pkgname/${_pkgname} "$pkgdir/usr/bin/${_pkgname}"
+ # install -Dm755 $srcdir/$pkgname/confcheck "$pkgdir/usr/bin/confcheck"
+}
+