summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcoder31012024-02-17 12:37:27 +0000
committercoder31012024-02-17 12:37:27 +0000
commit8d8a439ac794965ae5b7fabe3a15ad8e749c3610 (patch)
tree84e518d7f04cb6a249b61e0c66bd86c86fd8fa42 /PKGBUILD
parentd688549c9f29de85927c6d270a9ab8855801fafc (diff)
downloadaur-cpeditor-git.tar.gz
Update from CI: 7.0.1.r3.g21813202
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 24 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c6d1b7c96991..e4d04b97b9ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,24 @@
pkgname=cpeditor-git
_pkgname=cpeditor
-pkgver=7.0.1.r2.g0613a9c2
+pkgver=7.0.1.r3.g21813202
pkgrel=1
pkgdesc='The editor for competitive programming'
arch=('x86_64')
url='https://github.com/cpeditor/cpeditor'
-license=('GPL3')
-depends=('qt5-base' 'syntax-highlighting5' 'hicolor-icon-theme')
+license=('GPL-3.0-or-later')
+depends=(
+ 'qt5-base'
+ 'qt5-svg'
+ 'syntax-highlighting5'
+ 'hicolor-icon-theme'
+)
makedepends=(
- "cmake"
- "git"
- "ninja"
- "python3"
- "qt5-tools"
+ 'cmake'
+ 'git'
+ 'ninja'
+ 'python3'
+ 'qt5-tools'
)
optdepends=(
'cf-tool: submit to Codeforces'
@@ -25,14 +30,16 @@ optdepends=(
'wakatime: track coding stats'
)
provides=('cpeditor')
-conflicts=("cpeditor")
+conflicts=('cpeditor')
-source=('git+https://github.com/cpeditor/cpeditor.git'
+source=(
+ 'git+https://github.com/cpeditor/cpeditor.git'
'git+https://github.com/cpeditor/QtFindReplaceDialog.git'
'git+https://github.com/cpeditor/lsp-cpp.git'
'git+https://github.com/itay-grudev/singleapplication.git'
'git+https://github.com/MikeMirzayanov/testlib.git'
- 'git+https://github.com/cpeditor/qhttp.git')
+ 'git+https://github.com/cpeditor/qhttp.git'
+)
md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
@@ -43,15 +50,13 @@ pkgver() {
prepare() {
cd "$_pkgname"
- git submodule init
-
- git config submodule.third_party/QtFindReplaceDialog.url "$srcdir/QtFindReplaceDialog"
- git config submodule.third_party/lsp-cpp.url "$srcdir/lsp-cpp"
- git config submodule.third_party/singleapplication.url "$srcdir/singleapplication"
- git config submodule.third_party/testlib.url "$srcdir/testlib"
- git config submodule.third_party/qhttp.url "$srcdir/qhttp"
- git -c protocol.file.allow=always submodule update
+ for _source in "${source[@]:1}"; do
+ _name=$(basename "$_source" .git)
+ _path="third_party/$_name"
+ git config submodule."$_path".url "$srcdir/$_name"
+ git -c protocol.file.allow=always submodule update --init -- "$_path"
+ done
}
build() {