summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2019-05-25 21:27:45 +0100
committerGrey Christoforo2019-05-25 21:27:45 +0100
commitd86c215859a7a7d313f7295fc3f391817aab1f77 (patch)
tree90ea54a523a60e2ab7ce758e8087e5280ead166e /PKGBUILD
downloadaur-cufflinks-git.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53a4c8af1748
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Grey Christoforo <first name @ last name .net>
+
+pkgname=cufflinks-git
+pkgver=v2.2.1.r83.gb4fa050
+pkgrel=1
+pkgdesc="Cufflinks assembles transcripts, estimates their abundances, and tests for differential expression and regulation in RNA-Seq samples.."
+arch=("x86_64")
+url="http://cole-trapnell-lab.github.io/projects/cufflinks/"
+license=('Artistic')
+depends=('boost' 'eigen3' 'python2' 'samtools' 'perl')
+source=('git+https://github.com/cole-trapnell-lab/cufflinks.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd cufflinks
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd cufflinks
+
+ sed -i 's,hash\[pos\]\.hash,(hash[pos].hash),g' src/GHash.hh
+
+
+
+ ./autogen.sh
+ # cufflinks uses python2 but archlinux uses python3 as default python
+ perl -i -pne '$_ =~ s/python/python2/ if $_ =~ /^#!\/usr/' src/cuffmerge
+
+ export EIGEN_CPPFLAGS="-I/usr/include/eigen3"
+ export LDFLAGS="-L/usr/lib -lboost_system"
+ ./configure --prefix=/usr
+}
+
+build() {
+ cd cufflinks
+ export EIGEN_CPPFLAGS="-I/usr/include/eigen3"
+ export LDFLAGS="-L/usr/lib -lboost_system"
+ make
+}
+
+package(){
+ cd cufflinks
+ make DESTDIR="$pkgdir/" install
+}