summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlad Wenter2017-09-10 20:31:46 +0200
committerAlad Wenter2017-09-10 20:31:46 +0200
commit98ec115e1c48b7363fd19e85d8d936c9f9e47e4b (patch)
tree286786f9471011a74a92a51f5845836adf159db9 /PKGBUILD
parent78a9d8f17c14b9ec6988ff095a15a3a80a6d9a35 (diff)
downloadaur-datamash-git.tar.gz
datamash-git: fix pkgver, rm .install, add https
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 9 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93ff811ba67c..e23ee2d94977 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,26 @@
-# Maintainer: jyantis <yantis@yantis.net>
+# Maintainer: Alad Wenter <alad@mailbox.org>
+# Maintainer: jyantis <yantis@yantis.net>
# Based on the PKGBUILD for datamash from
# Timothy Rice <t.rice@ms.unimelb.edu.au>
-
pkgname=datamash-git
-pkgver=v1.0.6.r54.gf8ae71f
-pkgrel=3
+pkgver=1.2.r4.gfd49457
+pkgrel=1
pkgdesc='A command-line program which performs numeric, textual and statistical operations on plain text data.'
-arch=('any')
+arch=('x86_64' 'i686')
url='https://www.gnu.org/software/datamash/'
license=('GPL')
-source=('git://git.sv.gnu.org/datamash.git')
+source=('git+https://git.savannah.gnu.org/git/datamash.git')
sha256sums=('SKIP')
depends=('glibc')
+# XXX rsync/wget are only needed for .po files in bootstrap.
makedepends=('git' 'gperf' 'rsync' 'wget')
conflicts=('datamash')
provides=('datamash')
-install=datamash.install
+
pkgver() {
cd datamash
- set -o pipefail
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
- # git describe --long | sed -r 's/^v//' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//; s/-/.r/; s/-/./'
}
build() {