aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Fordham2017-05-02 17:01:03 +1000
committerChris Fordham2017-05-02 17:01:03 +1000
commit4be160ab0656cd5788ef9bef42e08f18942da03b (patch)
tree01e94b12443b1a0227e96f7567fde3c4726a9c79 /PKGBUILD
parentaa879fea43f40c4b51ce4d43f459c0054034633d (diff)
downloadaur-4be160ab0656cd5788ef9bef42e08f18942da03b.tar.gz
Add in docker-proxy from libnetwork.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 046b7cc0b3d4..464aac260f14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,10 +36,12 @@ options=('!strip')
source=('docker::git+https://github.com/docker/docker.git'
'containerd::git+https://github.com/docker/containerd.git#commit=78fb8f45890a601e0fd9051cf9f9f74923e950fd'
'runc::git+https://github.com/docker/runc.git#commit=51371867a01c467f08af739783b8beafc154c4d7'
+ 'libnetwork::git+https://github.com/docker/libnetwork.git#commit=0f534354b813003a754606689722fe253101bc4e'
'docker.install')
md5sums=('SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'1a8e60447794b3c4f87a2272cc9f144f')
pkgver() {
@@ -61,6 +63,9 @@ prepare() {
pushd "$srcdir/containerd"
git checkout -q "$CONTAINERD_COMMIT"
popd
+ pushd "$srcdir/libnetwork"
+ git checkout -q "$CONTAINERDLIBNETWORK_COMMIT"
+ popd
# apply any patches for runc
pushd "$srcdir/runc"
@@ -90,6 +95,12 @@ build() {
LDFLAGS= make
popd
+ # docker-proxy (from libnetwork)
+ ln -svf "$srcdir/libnetwork" "$GOPATH/src/github.com/docker/"
+ pushd "$GOPATH/src/github.com/docker/libnetwork"
+ go build -ldflags="$PROXY_LDFLAGS" -o ./bin/docker-proxy 'github.com/docker/libnetwork/cmd/proxy'
+ popd
+
# docker
pushd docker
export AUTO_GOPATH=1
@@ -121,6 +132,9 @@ package() {
done
popd
+ # docker-proxy binary (from libnetwork)
+ install -Dm755 "$GOPATH/src/github.com/docker/libnetwork/bin/docker-proxy" "$pkgdir/usr/bin/docker-proxy"
+
cd docker
_dockerver="$(cat VERSION)"
install -Dm755 "bundles/$_dockerver/dynbinary-client/docker-$_dockerver" "$pkgdir/usr/bin/docker"