summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Waymann2024-06-16 15:52:23 +0200
committerLukas Waymann2024-06-16 15:52:23 +0200
commit3e0b075e5bb93a2f130a1e994be8250c6b8a71dc (patch)
treed7965ce646802664b71b3e3ba87ef538aa39c1c6 /PKGBUILD
downloadaur-elles-bin.tar.gz
Add initial PKGBUILD and generated .SRCINFO file
https://wiki.archlinux.org/title/Creating_packages https://wiki.archlinux.org/title/PKGBUILD https://wiki.archlinux.org/title/Arch_package_guidelines https://wiki.archlinux.org/title/AUR_submission_guidelines https://wiki.archlinux.org/title/.SRCINFO https://wiki.archlinux.org/title/Makepkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43aae55864bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Lukas Waymann <io@meribold.org>
+
+pkgname=elles-bin
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='A nicer /bin/ls'
+arch=(x86_64)
+url=https://github.com/arp242/elles
+license=(MIT)
+provides=(elles)
+conflicts=(elles)
+
+source=("https://github.com/arp242/elles/releases/download/v$pkgver/elles-v$pkgver-linux-amd64.gz"
+ "https://raw.githubusercontent.com/arp242/elles/master/LICENSE")
+sha256sums=(ba0c65c96079f9120dca32fca30a8ebbec0b85bad2933d2938b555868dff35dd
+ 401b054d7378650e9289148ff085496190a301820c93eaacec84f1ae46cb2d22)
+
+package() {
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D "elles-v$pkgver-linux-amd64" "$pkgdir/usr/bin/elles"
+}