summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsteffeno2023-08-05 22:19:22 +0200
committersteffeno2023-08-05 22:19:22 +0200
commitbf0d39f44938bb65906494110f39e44aece99c90 (patch)
tree9396054eb50ad18d5ce01bc16b7eb5266a76d4a5 /PKGBUILD
downloadaur-ext4magic-patch-extent-free.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..925bb0a33751
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: steffeno <steffeno dash etc at protonmail dot com>
+
+_pkgname=ext4magic
+pkgname=$_pkgname-patch-extent-free
+pkgver=0.3.2
+pkgrel=4
+pkgdesc="Upstream $_pkgname-$pkgver package, patched not to segfault"
+arch=('x86_64')
+url='https://sourceforge.net/projects/ext4magic/'
+license=('GPL2')
+depends=('bzip2' 'file' 'util-linux' 'e2fsprogs')
+conflicts=($_pkgname)
+source=("$url/files/$_pkgname-$pkgver.tar.gz"
+ "$url/files/Patches/workaround.patch"
+ '01-i_dir_acl.patch'
+ '02-Fix-undefined-reference-to-makedev.patch'
+ '03-Fix-segfault-extent-free.patch')
+sha256sums=('8d9c6a594f212aecf4eb5410d277caeaea3adc03d35378257dfd017ef20ea115'
+ '89468a7857778bd171490cddfc1f4ce8b8308c46353e8c01998dc054373f5fff'
+ '2b5cde2612370f49fa9ed8442c23425499bdcf67aaba442087eb11f1c8b51e06'
+ '850378bcee22c9e4888c7ebb77085db29747383e5a272795be18341d4426f2db'
+ 'b8f4660c11c7e91edd85caa848a009b1a11b168cb80dec9cf7f23ac9d90dcdab')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ echo "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
+
+build() {
+ cd $_pkgname-$pkgver
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: