summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMattia Borda2022-12-04 11:22:17 +0100
committerMattia Borda2022-12-04 11:22:17 +0100
commit9d82d41fa4b9fe6147addf63e146217fe570705b (patch)
tree38c87041730e1fdd9739db9157e2a6acd0a36287 /PKGBUILD
downloadaur-file-roller-gtk4.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd88cd26809c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Mattia Borda <mattiagiovanni.borda@icloud.com>
+
+pkgname=file-roller-gtk4
+pkgver=44.alpha
+pkgrel=1
+pkgdesc="WIP GTK4 port of the File Roller archive utility"
+url="https://wiki.gnome.org/Apps/FileRoller"
+arch=(i686 x86_64 armv7h aarch64)
+license=(GPL2)
+depends=(libadwaita libarchive libportal-gtk4 libnautilus-extension)
+makedepends=(git meson yelp-tools)
+checkdepends=(appstream-glib)
+optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
+ 'unrar: better RAR archive support'
+ 'unace: ACE archive support'
+ 'lrzip: lrzip archive support'
+ 'squashfs-tools: squashfs image support')
+conflicts=(${pkgname%-gtk4})
+provides=(${pkgname%-gtk4})
+groups=(gnome)
+source=("git+https://gitlab.gnome.org/GNOME/${pkgname%-gtk4}.git#branch=wip/gtk4")
+b2sums=('SKIP')
+
+build() {
+ arch-meson ${pkgname%-gtk4} build
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}