summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLiao Junxuan2022-01-24 00:35:12 +0800
committerLiao Junxuan2022-01-24 00:36:32 +0800
commit8fa753d13186df7658ba55b3680c4c2be3d73d94 (patch)
tree708ae26ecd1421aa1f61cf73de9a0e583ef7e44c /PKGBUILD
parentcf6f1c28988db38c00c738c954fce72684919934 (diff)
downloadaur-find-cursor.tar.gz
update to 1.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29e05e1aec88..b3fa70b4fd3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,21 @@
+# Maintainer: Liao Junxuan <mikeljx at 126 dot com>
pkgname=find-cursor
-pkgver=1.7
+pkgver=1.8
pkgrel=1
pkgdesc="Simple XLib program to highlight the cursor position in X11"
arch=('x86_64')
url="https://github.com/arp242/find-cursor"
license=('MIT')
-depends=(libx11 libxcomposite libxdamage libxrender)
-source=("https://github.com/arp242/find-cursor/archive/refs/tags/v$pkgver.tar.gz")
-sha256sums=('4ee50e5bedae92eec6b0f88a0dc1a6e9b783d2c34207b9b08e50dc7af069d610')
+depends=(libx11 libxext libxcomposite libxrender libxdamage)
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
+ 0001-specify-the-libraries-after-source-files.patch)
+sha256sums=('2718ba5c65fe9b6a5a6e02989eba4ebacce1b9536e82896ac67f25203d7554bb'
+ '4bd02c0073d1e67af2ae5be6d2b6e7ac5376ea825ff97bfe0f7c4a792de6e766')
+
+prepare() {
+ cd "$srcdir/find-cursor-$pkgver"
+ patch --strip=1 -i "$srcdir"/0001-specify-the-libraries-after-source-files.patch
+}
build() {
cd "$srcdir/find-cursor-$pkgver"