summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDeposite Pirate2018-08-28 15:34:30 +0200
committerDeposite Pirate2018-08-28 15:34:30 +0200
commit4b2e162f02e5b0a65e7986ce559df8ecc8bc52fe (patch)
tree15742664f1a27fae94cbf0f437bd39de4cc6f4ac /PKGBUILD
parent8c6905f35a12e1252e6fef6306f301d363611b3e (diff)
downloadaur-freeblocks-git.tar.gz
* Small updates
* Use distro CFLAGS modified: .SRCINFO modified: PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a90681413850..817a9ac79908 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Christoph J. Thompson <thompsonc@protonmail.ch>
+# Maintainer: Christoph J. Thompson <thompsonc at protonmail dot ch>
pkgname=freeblocks-git
-pkgver=r181.g68b11ed
-pkgrel=1
+pkgver=r193.gfa7088c
+pkgrel=2
pkgdesc="Tetris Attack-like puzzle game"
arch=('i686' 'x86_64')
url="https://github.com/dorkster/freeblocks"
@@ -24,7 +24,9 @@ pkgver() {
build() {
cd "${pkgname}"
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ cmake \
+ -DCMAKE_C_FLAGS="${CFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=/usr .
make
}
@@ -32,4 +34,3 @@ package() {
cd "${pkgname}"
make DESTDIR="${pkgdir}" install
}
-