summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEthan Kerrick2023-12-21 19:02:46 -0500
committerEthan Kerrick2023-12-21 19:02:46 -0500
commit535670db507fb56745ade590f44a6cdd2675193a (patch)
treece80b0fb4f4ee2f8e96f3c473691b03462a0e4e8 /PKGBUILD
parent44db5dc391dc4a0d815aeadb9e432355da0e1750 (diff)
downloadaur-gargoyle-git.tar.gz
modifed build, and packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 8 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7d33e8b7a56..b564a7d434a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,20 @@
# Marcin Skory <armitage at q84fh dot net>
# with Contribution of Eric Forgeot < http://ifiction.free.fr >
pkgname=gargoyle-git
-pkgver=2019.1.r514.g6914267
+pkgver=2022.1.r563.gbde657b4
pkgrel=1
pkgdesc="Interactive Fiction multi-interpreter that supports all major IF formats (development version)"
arch=('i686' 'x86_64' 'armv6h')
url="https://github.com/garglk/garglk"
license=('GPL')
depends=('sdl2_mixer' 'sdl2' 'freetype2' 'qt5-base' 'fontconfig' 'libjpeg' 'libpng')
-makedepends=('cmake' 'pkgconfig' 'desktop-file-utils' 'git')
+makedepends=('cmake' 'pkgconfig' 'desktop-file-utils' 'git' 'fmt')
+optdepends=('speech-dispatcher: text-to-speech support')
provides=('gargoyle-git')
conflicts=('gargoyle-mod' 'gargoyle')
replaces=('gargoyle-mod' 'gargoyle')
groups=(inform)
-source=("$pkgname::git+https://github.com/garglk/garglk.git" \
- "gargoyle-git.install")
+source=("$pkgname::git+https://github.com/garglk/garglk.git" "gargoyle-git.install")
install=${pkgname}.install
sha512sums=('SKIP'
'1fa602865745c1c9801178ee9b24be86215f2af4f9ee3f4f3b3c0606a87aba32a67c9c5343b481332c8fc97ff6c1a5e447f074d116c0cc5b255af35098096e6e')
@@ -29,23 +29,12 @@ pkgver() {
}
build() {
- cd "$pkgname"
- mkdir -p build
- cd build
- # Don't build with Text-to-Speech support.
- # TODO: Make this an optional package.
- cmake .. -DWITH_TTS=false -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake -S "${pkgname}" -B "build" -DWITH_TTS=DYNAMIC -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
+ cmake --build "build"
}
package() {
- cd "$pkgname/build"
- make DESTDIR="$pkgdir/" install
-
- cd -
- local gsrcdir="$pkgname"
-
+ cmake --install "build"
# Install default config
- install -dm755 "$pkgdir/etc"
- install -m755 "$gsrcdir/garglk/garglk.ini" "$pkgdir/etc"
+ install -Dm755 "$srcdir/${pkgname}/garglk/garglk.ini" "$pkgdir/etc/garglk.ini"
}