summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIlya Basin2016-04-03 12:52:29 +0300
committerIlya Basin2016-04-03 12:52:29 +0300
commit7e936eb50a70ea3f1deea2b602f6cba2c22b3c91 (patch)
treec92ccf9ca85e6f11cc62dc6d3c70b8a39361a7b8 /PKGBUILD
downloadaur-gedit-autotab-git.tar.gz
root
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13e4ebfff4ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ilya Basin <basinilya@gmail.com>
+# Contributor: Evangelos Foutras <foutrelis@gmail.com>
+
+_pkgname=gedit-autotab
+pkgname=gedit-autotab-git
+pkgver=r45.cc70af2
+pkgrel=1
+pkgdesc="Automatically detect tab preferences for source files"
+arch=('any')
+url="https://github.com/kapouer/gedit-autotab"
+license=('GPL3')
+depends=('gedit')
+source=('git+https://github.com/kapouer/gedit-autotab.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/gedit-autotab"
+ #patch -Np1 -i "$srcdir/nosavelistener.patch"
+ install -d "$pkgdir/usr/lib/gedit/plugins"
+ install -m644 -t "$pkgdir/usr/lib/gedit/plugins/" autotab.{plugin,py}
+}
+
+# vim:set ts=2 sw=2 et:
+