summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Arndt2023-10-16 22:23:30 +0200
committerChristopher Arndt2023-10-16 22:23:30 +0200
commit647951c75a9cb7ee82458518c24ce19a4637215a (patch)
tree415dc46bc781eb8c61645799026a73c12ef9bbb6 /PKGBUILD
parent633e9e38aa86b63dbc2b20b7afe835a7bf2d840f (diff)
downloadaur-geonkick-git.tar.gz
Fix url, source url, vst3 build, check function and doc file list
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4a607fb6f5e..f358c21e98a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
_plugin_uri='http://geontime.com/geonkick'
_pkgname=geonkick
pkgname="${_pkgname}-git"
-pkgver=2.10.0.r1199.990cb7ba
+pkgver=2.10.2.r34.228bba0
pkgrel=1
pkgdesc='A free software percussion synthesizer (git version)'
arch=(x86_64)
-url='https://gitlab.com/geonkick/geonkick'
-license=(GPL3)
+url='https://geonkick.org'
+license=(GPL-3.0-or-later)
groups=(lv2-plugins pro-audio vst3-plugins)
depends=(gcc-libs glibc cairo hicolor-icon-theme libx11 libsndfile)
-makedepends=(cmake git jack lv2 rapidjson sord)
+makedepends=(cmake git jack lv2 rapidjson sord vst3sdk)
checkdepends=(lv2lint)
optdepends=(
'jack: for stand-alone application'
@@ -20,7 +20,7 @@ optdepends=(
)
provides=($_pkgname $_pkgname-common $_pkgname-lv2 $_pkgname-standalone $_pkgname-vst3)
conflicts=($_pkgname $_pkgname-common $_pkgname-lv2 $_pkgname-standalone $_pkgname-vst3)
-source=("$_pkgname::git+https://gitlab.com/geonkick/geonkick.git")
+source=("$_pkgname::git+https://gitlab.com/Geonkick-Synthesizer/geonkick.git")
sha256sums=('SKIP')
pkgver() {
@@ -35,15 +35,13 @@ build() {
-S $_pkgname \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DGKICK_VST3=ON \
+ -DVST3_SDK_PATH=/usr/src/vst3sdk \
-W no-dev
cmake --build $_pkgname-build
}
check() {
- cp -av $_pkgname-build/plugin/lv2/*.so $_pkgname/plugin/lv2/$_pkgname.lv2/
- lv2lint -Mpack -I $_pkgname/plugin/lv2/$_pkgname.lv2/ "$_plugin_uri"
- rm $_pkgname/plugin/lv2/$_pkgname.lv2/*.so
+ lv2lint -S nowarn -M pack -I $_pkgname/src/plugin/lv2/$_pkgname.lv2 "$_plugin_uri"
}
@@ -54,7 +52,7 @@ package() {
install -vDm 644 data/$_pkgname.desktop \
-t "$pkgdir"/usr/share/applications
# documentation
- install -vDm 644 README.md NEWS.md \
+ install -vDm 644 AUTHORS README.md CHANGELOG.md \
-t "$pkgdir"/usr/share/doc/$pkgname
install -vDm 644 doc/*.{md,png} \
-t "$pkgdir"/usr/share/doc/$pkgname