summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatti Niemenmaa2019-01-04 14:09:38 +0200
committerMatti Niemenmaa2019-01-04 17:33:12 +0200
commit54c8df6fea79e88613b128051ea76fc43352ce46 (patch)
tree4a736d5c411d59dd0bb07e1101413be861c27ed4 /PKGBUILD
downloadaur-git-explode.tar.gz
Initial commit for 0.0.1, seems to work
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..268369a67ebc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+pkgname=git-explode
+depends=(git git-deps python python-ostruct python-setuptools)
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Explode linear sequence of git commits into topic branches'
+arch=(any)
+url=https://github.com/aspiers/git-explode
+license=(GPL2)
+source=(https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz)
+sha512sums=('49513e4ca5c1212b1fd2a5671d988c1fdc0644d9e5477acc5b5404fdd3af1390d01826edb72824511f3b93a2628bed762f44658c031ea4e7f948cc217ccd6764')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 README.rst "$pkgdir/usr/share/doc/$pkgname/README"
+}
+
+# Depends on having the git repo instead of just the source tarball.
+#
+#checkdepends=(python-pytest python-pytest-cov)
+#check() {
+# cd "$srcdir/$pkgname-$pkgver"
+# python setup.py test
+#}