summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastian Reuße2017-09-11 09:39:30 +0200
committerSebastian Reuße2017-09-11 09:39:30 +0200
commitbdbaaf3ce4ae18c608149765b387b202691910d0 (patch)
treed74564c25e2edf3a38c4fef39617d3c56cccd99c /PKGBUILD
parenta2536f455406d863fbf31c11b3cfceb426b13ccc (diff)
downloadaur-git-remote-gcrypt-git.tar.gz
pkgver: use only regular version tags
Upstream also tags Debian releases separately, which contain slashes and throw off makepkg. Make sure to just use the regular version tags.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e22b94de26c..fe3c23c21e3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ md5sums=(SKIP)
pkgver() {
cd "$_gitname"
- git describe --long --tags | \
+ git describe --long --tags --match "[[:digit:]]*" | \
sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//;'
}