summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorchron2015-07-21 13:18:56 +0200
committerchron2015-07-21 13:18:56 +0200
commitc5a792262bc3c43e4543dd9da6ecfa87e9445979 (patch)
treec52c8574868533c7eb71ce01d0db1d2a32622a8f /PKGBUILD
downloadaur-glogic.tar.gz
Copied kusakata files from AUR3, minor changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a4de6c454fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor kusakata <shohei atmark kusakata period com>
+# Maintainer chron <chronischzuspaet at gmail dot com>>
+
+pkgname=glogic
+pkgver=2.6
+pkgrel=2
+pkgdesc='An educational graphical logic circuit simulator'
+arch=('any')
+url="https://launchpad.net/glogic"
+license=('GPL3')
+depends=('hicolor-icon-theme' 'intltool' 'python' 'python-cairo')
+makedepends=('itstool')
+install=glogic.install
+source=("https://launchpad.net/glogic/trunk/${pkgver}/+download/glogic-${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/glogic-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/glogic-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}
+
+sha256sums=('62fabbc39aa7d72491fb83aa0547385cbb89d7a593ad2fb80b019607593d1bde')