summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex2021-06-01 17:50:08 +0200
committerAlex2021-06-01 17:50:08 +0200
commit01aaf454d0a1858c823c8edf24dea2a748ec9546 (patch)
tree3cd43ed0729c5fa3aaeacd599f321b1a5b330f06 /PKGBUILD
parent6c3fc139a1142b54c816dbcb08ad342b20cb1b61 (diff)
downloadaur-gnome-shell-extension-shutdowntimer.tar.gz
Update to v30
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e7901f8c52b..a927b95d99cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer: Alex S. shantanna_at_hotmail_dot_com>
pkgname=gnome-shell-extension-shutdowntimer
-pkgver=21
+pkgver=v30
pkgrel=1
pkgdesc="Shutdown your device after a specific time. This extension adds a submenu to the status area."
arch=('any')
-url="https://github.com/neumann89/ShutdownTimer"
+url="https://github.com/neumann-d/ShutdownTimer"
license=('unknow')
+conflicts=('gnome-shell-extension-shutdowntimer-git')
depends=('gnome-shell')
-source=("git+https://github.com/neumann89/ShutdownTimer.git")
+source=("git+https://github.com/neumann-d/ShutdownTimer.git")
sha256sums=('SKIP')
+pkgver() {
+ cd $_pkgname
+ git describe --always --tags | tr '-' '_'
+}
+
package() {
- cd "${srcdir}/ShutdownTimer"
- mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions/"
- cp -af "ShutdownTimer@neumann" "${pkgdir}/usr/share/gnome-shell/extensions/"
+ cd "${srcdir}/ShutdownTimer"
+ mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions/"
+ cp -af "ShutdownTimer@neumann" "${pkgdir}/usr/share/gnome-shell/extensions/"
}