summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArcanusNEO2023-10-10 22:41:01 +0800
committerArcanusNEO2023-10-10 22:41:01 +0800
commitc42f29cbe221e911e82056773dd12b927d6ee4cb (patch)
treef99c1fbd9d37525540e90badfc314f9a7ad4e83c /PKGBUILD
downloadaur-gnome-shell-extension-windowisready_remover-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96aed7d1ac34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ArcanusNEO <admin@transcliff.top>
+_pkgname=gnome-shell-extension-windowisready_remover
+pkgname=$_pkgname-git
+pkgver=r35.f8bfd6f
+pkgrel=1
+pkgdesc='GNOME shell extension that removes the annoying "Windows is Ready" notification.'
+arch=("any")
+url="https://github.com/nunofarruca/WindowIsReady_Remover"
+license=("Apache-2.0")
+depends=("gnome-shell")
+makedepends=("git")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$pkgname::git+$url")
+b2sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ local _uuid="windowIsReady_Remover@nunofarruca@gmail.com"
+ find ${_uuid} -regextype posix-egrep -regex ".*\.(js|json)$" -exec install -Dm644 {} ${pkgdir}/usr/share/gnome-shell/extensions/{} \;
+}