summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHokuto2018-05-16 08:31:20 +0900
committerHokuto2018-05-16 08:31:20 +0900
commit7d8ec92bac4df26781918dc9a7b24616dde23e6a (patch)
tree4816dfbe02ba8a444497b8519b640ef8e26d15d3 /PKGBUILD
downloadaur-gtk-theme-windows-longhorn-git.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66db88729423
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Hokuto <abrahamhokuto@outlook.com>
+
+pkgname=gtk-theme-windows-longhorn-git
+pkgver=r95.8afdf4f
+pkgrel=1
+pkgdesc="Longhorn beta themes"
+arch=('any')
+url="https://github.com/Elbullazul/Longhorn-Collaboration"
+license=('GPL')
+depends=()
+makedepends=('git') # 'bzr', 'git', 'mercurial' or 'subversion'
+source=('git+https://github.com/Elbullazul/Longhorn-Collaboration.git')
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/Longhorn-Collaboration"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/Longhorn-Collaboration"
+
+ rm -rf .git
+ rm Readme.md
+ rm 'Tips for themes.md'
+
+ mkdir -p "$pkgdir/usr/share/themes"
+
+ cp -r * "$pkgdir/usr/share/themes/"
+
+ find "$pkgdir/usr/share/themes/" -type d -exec \
+ chmod 755 {} \;
+
+ find "$pkgdir/usr/share/themes/" -type f -exec \
+ chmod 644 {} \;
+}