summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBurke Cates2017-03-03 17:36:43 -0800
committerBurke Cates2017-03-03 17:36:43 -0800
commit05531a66c2d4a4212ade1882a234cba752231d5c (patch)
treefa130e8db08f2ad40e17801c61406e917ece57b7 /PKGBUILD
downloadaur-gtypist-single-space.tar.gz
initial commit.
pull commit-specific archive from github and move files into place during prepare()
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a9948abc395
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Burke Cates <burke.cates+arch@gmail.com>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Ben Mazer <blm@groknil.org>
+# Contributor: Mike Douglas <code_monkey@gooeylinux.org>
+
+_pkgname=gtypist
+pkgname=gtypist-single-space
+pkgver=2.9.5
+pkgrel=3
+_overlay_hash=f3b67b6d229a1d8c7bf0b3151eba51a885a25185
+pkgdesc="universal typing tutor with single spaces after sentences in lessons."
+arch=('i686' 'x86_64')
+url="https://github.com/inaimathi/gtypist-single-space"
+license=("GPL")
+depends=('ncurses' 'perl')
+makedepends=('emacs')
+conflicts=('gtypist')
+provides=('gtypist')
+source=(ftp://ftp.gnu.org/gnu/gtypist/$_pkgname-$pkgver.tar.gz
+ https://github.com/inaimathi/gtypist-single-space/archive/$_overlay_hash.zip
+ ncurses.patch)
+md5sums=('6098c32890f2437384b5efe4e993fb32'
+ '492c92eb0917ec3b39567c2a9cb87514'
+ 'a836141e70941b7e0d3477bc8ecdecdf')
+
+prepare() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ patch -p1 <"$srcdir"/ncurses.patch
+ autoreconf
+ mv "$srcdir"/"$pkgname"-"$_overlay_hash"/*.typ "$srcdir"/"$_pkgname"-"$pkgver"/lessons/
+}
+
+build() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/$_pkgname-$pkgver
+ make prefix="$pkgdir"/usr install
+ rm -f "$pkgdir"/usr/share/info/dir
+}