summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorprocrastinator2015-06-27 18:28:59 +0100
committerprocrastinator2015-06-27 18:28:59 +0100
commitef4cf3867fcec6a5be1967ebae8ee23189a1ffdb (patch)
treedfa9bd06727c60025d0f76d5abf1dbeb5abf924a /PKGBUILD
downloadaur-gyazo-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef9555a8a119
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: procrastinator
+pkgname=gyazo-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="Launch the Gyazo app and drag your mouse to grab the screen."
+arch=('any')
+url="http://gyazo.com"
+license=('GPL')
+groups=(multimedia)
+depends=('ruby' 'xclip' 'imagemagick')
+makedepends=('git')
+conflicts=('gyazo')
+
+_gitremote="https://github.com/gyazo/Gyazo-for-Linux.git"
+_gitname="Gyazo-for-Linux"
+
+build() {
+ cd "$srcdir"
+ if [ -d $_gitname ] ; then
+ git pull origin
+ msg "Local repository updated."
+ else
+ git clone $_gitremote $_gitname
+ fi
+}
+
+package() {
+ install -D -m755 "$srcdir/$_gitname/src/gyazo.rb" "$pkgdir/usr/bin/gyazo"
+ install -D -m664 "$srcdir/$_gitname/src/gyazo.desktop" "$pkgdir/usr/share/applications/gyazo.desktop"
+ install -D -m644 "$srcdir/$_gitname/icons/gyazo.png" "$pkgdir/usr/share/pixmaps/gyazo.png"
+
+}
+