summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoryantene2017-08-30 23:41:12 +0900
committeryantene2017-08-30 23:43:18 +0900
commit81b2e2c8abf2fb1eb3627088737614e8a84cb56b (patch)
treee84c2cc17804ab8bd4d8f5d3a066ab6f054558c7 /PKGBUILD
downloadaur-hengband-git.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..117f9a95b256
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: yantene <contact at yantene dot net>
+
+pkgname=hengband-git
+_gitname=hengband
+pkgver=v2.1.4.r376.g02901956
+pkgrel=1
+pkgdesc="A variant of angband"
+arch=('i686' 'x86_64')
+url="http://hengband.osdn.jp"
+license=('unknown')
+depends=('ncurses')
+source=(git://git.osdn.net/gitroot/hengband/hengband.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ git describe --tags --always | sed -e 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $_gitname
+ ./bootstrap
+}
+
+build() {
+ cd $_gitname
+
+ ./configure --with-libpath=/usr/lib/hengband/
+ make
+}
+
+package() {
+ cd $_gitname
+
+ install -d "${pkgdir}/usr/lib"
+
+ install -D -m755 "src/hengband" "${pkgdir}/usr/bin/hengband"
+ cp -R ./lib/ "${pkgdir}/usr/lib/hengband"
+ chmod -R 775 "${pkgdir}/usr/lib/hengband"
+ chown -R root:users "${pkgdir}/usr/lib/hengband"
+
+# removing unneeded files
+ find "${pkgdir}" -iname delete.me -delete
+ find "${pkgdir}" -iname Makefile -delete
+ find "${pkgdir}" -iname Makefile.am -delete
+ find "${pkgdir}" -iname Makefile.in -delete
+}