summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2020-04-10 22:38:54 +0200
committerhaawda2020-04-10 22:38:54 +0200
commit17cbc3b37999436fab40164994ea2b212957c5c2 (patch)
tree94c24f70fd51c0555238c9fb5e30837eba83ad87 /PKGBUILD
parente2fee8dcde159eefbb72127cb7e9ef07063b4faa (diff)
downloadaur-hop.tar.gz
introduce variable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e814c83c6a15..ccc1843c9ab4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,14 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=hop
+_biglooversion=4.3f
epoch=1
pkgver=3.1.0
-pkgrel=5
+pkgrel=6
pkgdesc="Software Development Kit for the Web"
arch=('x86_64')
license=('GPL' 'LGPL')
-depends=('bigloo' 'gmp' 'libunistring' 'libuv' 'avahi' 'sqlite')
+depends=("bigloo=${_biglooversion}" 'gmp' 'libunistring' 'libuv' 'avahi' 'sqlite')
makedepends=('git')
conflicts=('hop')
provides=('hop')
@@ -23,7 +24,7 @@ build() {
cd $pkgname
./configure --prefix=/usr --etcdir=/etc/hop --mandir=/usr/share/man \
--disable-ssl --bigloobindir=/usr/bin --link=dynamic \
- --bigloolibdir=/usr/lib/bigloo/4.3f
+ --bigloolibdir=/usr/lib/bigloo/${_biglooversion}
sed -i 's/, -static-all-bigloo//' share/Makefile
LD_LIBRARY_PATH="$PWD/lib/hop/3.1.0/" make
}