summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Chesters2023-11-08 20:33:47 +0100
committerDaniel Chesters2023-11-08 20:33:47 +0100
commit773ee0797b1c6ffec88b26a5489dc067c7ceab9c (patch)
treefae00544b86468abaef6252f1e62a0a3c8f9bdf6 /PKGBUILD
parente5c5f0db54be791d60c771457d971985c29b6682 (diff)
downloadaur-i3wsr-git.tar.gz
Fix: add python as make dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 47fc29731104..81a014faa950 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer : Daniel Chesters <daniel.chesters@gmail.com>
+# Maintainer : Daniel Chesters <archlinux@coin-coin.xyz>
pkgname=i3wsr-git
-pkgver=2.0.0.r2.ge28739c
+pkgver=2.1.1.r5.g7792fd8
pkgrel=1
pkgdesc="A small program to change the name of an i3 workspace based on its contents."
url="https://github.com/roosta/i3wsr"
depends=('i3-wm')
-makedepends=('cargo' 'git')
+makedepends=('cargo' 'git' 'python')
arch=('i686' 'x86_64')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -15,19 +15,19 @@ source=("$pkgname::git+https://github.com/roosta/i3wsr.git")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
- cargo build --release
+ cd "$pkgname"
+ cargo build --release
}
package() {
- cd "$pkgname"
- install -Dm755 "target/release/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "$pkgname"
+ install -Dm755 "target/release/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
# vim:set ts=2 sw=2 et: