summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKonstantin Shalygin2019-11-08 11:11:17 +0700
committerKonstantin Shalygin2019-11-08 11:11:17 +0700
commit5ecab975563780f59e3d75abf562e2e87049c59e (patch)
treeab0e2ba6b0c9016f8c7f817ddf272532bddd4592 /PKGBUILD
parent476b9b7bc78d0ef12a7b33334bc4bd29dbe832fa (diff)
downloadaur-ipt_iftag.tar.gz
Fixed regex for 5.3+ Arch Kernels.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eaf5c12f8707..ac17459ccf5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,11 +12,9 @@ depends=('linux' 'iptables')
makedepends=('git' 'libtool' 'gcc' 'gzip' 'gawk' 'sed')
source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
-# define 'lts' for linux-lts package
-_linux_custom="ARCH"
# define '-lts' for linux-lts package
-_linux_localversion=""
-_kernver="`pacman -Ql linux${_linux_localversion} | awk '/(\/modules\/)([0-9.-])+-(.*)-'${_linux_custom}'\/$/ {print $2}'`"
+_linux_custom=""
+_kernver="`pacman -Ql linux${_linux_custom} | awk '/(\/modules\/)([0-9.-])+-(.*)'${_linux_custom}'\/$/ {print $2}' | head -n1`"
pkgver() {
cd "${srcdir}/${pkgname}"