summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2022-06-19 00:00:04 +0200
committerMuflone2022-06-19 00:00:04 +0200
commitb34558445a44a9430923fd17bb1008c074c43553 (patch)
treebb07336bff7037ab5518583c00f491083427df7a /PKGBUILD
parent4cf4d9e664b51b1b5564cdf7f783ce2f3870158b (diff)
downloadaur-java-16-openjdk.tar.gz
Updated package java-16-openjdk 16.0.2.u7-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d6b8e51a0633..f70e0d5c1619 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ _majorver=16
_minorver=0
_securityver=2
_updatever=7
-pkgrel=1
+pkgrel=2
pkgver="${_majorver}.${_minorver}.${_securityver}.u${_updatever}"
_git_tag="jdk-${_majorver}.${_minorver}.${_securityver}+${_updatever}"
arch=('x86_64')
@@ -44,8 +44,8 @@ _nonheadless=(lib/libawt_xawt.{so,debuginfo}
lib/libsplashscreen.{so,debuginfo})
prepare() {
- # Avoid the use of any Java 8-14, actually incompatible with the build
- export JAVA_HOME="/usr/lib/jvm/$(archlinux-java status | tail -n +2 | sort | cut -d ' ' -f 3 | sort -nr -k 2 -t '-' | grep -vE '8-|9-|10-|11-|12-|13-|14-' -m 1)"
+ # Use only Java versions 15-16
+ export JAVA_HOME="/usr/lib/jvm/$(archlinux-java status | tail -n +2 | sort | cut -d ' ' -f 3 | sort -nr -k 2 -t '-' | grep -E '15-|16-' -m 1)"
}
build() {
@@ -70,6 +70,14 @@ build() {
_CXXFLAGS="${CXXFLAGS/-fno-plt/}"
fi
+ # TODO: Should be rechecked for the next releases
+ # compiling with -fexceptions leads to:
+ # /usr/bin/ld: /build/java-openjdk/src/jdk17u-jdk-17.0.3-2/build/linux-x86_64-server-release/hotspot/variant-server/libjvm/objs/zPhysicalMemory.o: in function `ZList<ZMemory>::~ZList()':
+ # /build/java-openjdk/src/jdk17u-jdk-17.0.3-2/src/hotspot/share/gc/z/zList.hpp:54: undefined reference to `ZListNode<ZMemory>::~ZListNode()'
+ # collect2: error: ld returned 1 exit status
+ _CFLAGS=${CFLAGS/-fexceptions/}
+ _CXXFLAGS=${CXXFLAGS/-fexceptions/}
+
# CFLAGS, CXXFLAGS and LDFLAGS are ignored as shown by a warning
# in the output of ./configure unless used like such:
# --with-extra-cflags="${CFLAGS}"