summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2021-01-12 17:52:34 -0500
committerVincent Grande2021-01-12 17:52:34 -0500
commitac59236c26e651703e42f22fed710bb047c4792c (patch)
treed5f38ebb68e73a8f07d09b031706e991b44648b9 /PKGBUILD
parent35f9c6985117998839fe8d5fb3b6a2c90b7f7e94 (diff)
downloadaur-lib32-keyutils-git.tar.gz
fix pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67ffff08703d..bfebddd51861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,9 +17,17 @@ conflicts=(lib32-keyutils)
source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git")
sha512sums=('SKIP')
+_commit() {
+ # Convert HEAD into a shortened commit id:
+ git rev-parse --short HEAD
+}
+
pkgver() {
cd keyutils
- git describe --tags | sed 's/-/+/g'
+
+ # Suggestions for improvement welcome!
+ printf '%s.r%s.%s' \
+ "$(_commit)"
}
build() {