summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67ffff08703d..bfebddd51861 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,9 +17,17 @@ conflicts=(lib32-keyutils)
source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git")
sha512sums=('SKIP')
+_commit() {
+ # Convert HEAD into a shortened commit id:
+ git rev-parse --short HEAD
+}
+
pkgver() {
cd keyutils
- git describe --tags | sed 's/-/+/g'
+
+ # Suggestions for improvement welcome!
+ printf '%s.r%s.%s' \
+ "$(_commit)"
}
build() {