summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortaoky2023-09-25 23:57:30 +0800
committertaoky2023-09-25 23:57:30 +0800
commitd5a5d234b72321740fcdac652b35e317fa0a5636 (patch)
treec6ad1b0c6e39c08d1a690d8bc69638fdce8dd2dd /PKGBUILD
parent922355231b7540ee419bb4dfd82e3d137d198aaf (diff)
downloadaur-libdecor-git.tar.gz
Bug fixes
- Fix depends and makedepends list - Fix license path
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 404b1aa95e9f..ded7c100d932 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
pkgdesc='Client-side decorations library for Wayland clients'
pkgname=libdecor-git
_pkgname=libdecor
-pkgver=0.1.0+60+g3f3e5e1
+pkgver=0.2.0
pkgrel=1
url="https://gitlab.freedesktop.org/libdecor/libdecor"
license=('MIT')
arch=('x86_64')
-depends=('wayland' 'pango' 'dbus' 'egl-wayland' 'libxkbcommon')
-makedepends=('cmake' 'ninja' 'meson' 'wayland-protocols>=1.32')
+depends=('wayland' 'pango' 'dbus' 'egl-wayland' 'libxkbcommon' 'gtk3')
+makedepends=('cmake' 'ninja' 'meson' 'wayland-protocols' 'git')
source=("git+https://gitlab.freedesktop.org/libdecor/libdecor.git")
sha512sums=('SKIP')
conflicts=('libdecor')
@@ -34,6 +34,6 @@ check () {
package () {
meson install -C _build --destdir "${pkgdir}"
- install -Dm644 "${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "${_pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}