summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Weißschuh2024-01-03 16:43:09 +0100
committerThomas Weißschuh2024-01-03 16:43:09 +0100
commitb65434d08cdc7fb1892084c7bf546a70e9f058f4 (patch)
treec269c04b259b6934abeba7b8d5d93935a64d530b /PKGBUILD
parent1dbcded546c4e2c656961b2dbc547b19169fa9b6 (diff)
downloadaur-libeconf.tar.gz
0.6.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 363e8e318305..86030b113698 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Thomas Weißschuh <thomas t-8ch de>
pkgname=libeconf
-pkgver=0.4.9
+pkgver=0.6.0
pkgrel=1
pkgdesc="Enhanced config file parser, which merges config files placed in several locations into one."
arch=(x86_64)
@@ -9,8 +9,16 @@ url="https://opensuse.github.io/libeconf/"
license=('MIT')
depends=()
makedepends=(meson)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/openSUSE/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-md5sums=('c2523f6987c436a44b92917a028cbf7c')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/openSUSE/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
+ "https://github.com/openSUSE/libeconf/commit/1eef99e3144811c0acf905bb2e67a78633ee6eaf.patch")
+sha256sums=('766da6c606e33d9bc8ff0a4f4b72ce11a236d6cb046f21ebb9c4c6a9d078fff2'
+ '516761a2d64958f0845eee14bb61cf665f2c0bc139b97491673aee04276ce177')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -p1 < "$srcdir"/1eef99e3144811c0acf905bb2e67a78633ee6eaf.patch
+}
build() {
cd "$pkgname-$pkgver"