summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2023-01-25 01:29:26 -0600
committerLuis Martinez2023-01-25 01:34:13 -0600
commit566fbbe5350070c84e093dfe2c588415e41bab24 (patch)
tree74bc0778cda2ae0dc40d0cbc16ca3a55dc2c93aa /PKGBUILD
parent134ade5d8483ea3e881a5ee9f532efe028846c84 (diff)
downloadaur-libframe.tar.gz
packaging cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 18 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 599a0ee74739..142d76a622cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,27 @@
-# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+
pkgname=libframe
-_pkgname=${pkgname}
pkgver=8.30
-pkgrel=8
-pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite. ${_pkgname}"
-arch=(any)
+pkgrel=9
+pkgdesc="The LIGO Scientific Consortium Algorithm Library Suite"
+arch=('x86_64')
url="https://wiki.ligo.org/DASWG/LALSuiteInstall"
-license=('unknown')
+license=('custom')
groups=('lalsuite')
-depends=()
-makedepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=(!emptydirs)
-install=
-source=("http://software.ligo.org/lscsoft/source/${_pkgname}-${pkgver}.tar.gz")
+depends=('glibc')
+provides=("libFrame.so")
+source=("$pkgname-$pkgver.tar.gz::https://software.ligo.org/lscsoft/source/$pkgname-$pkgver.tar.gz")
sha256sums=('374743ccce835427a0900590a515c112661760e12ec596159d3f86073dd099da')
+
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- ./configure --prefix=${pkgdir}/usr CFLAGS='-O3 -Wno-error'
- make -j
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
}
-#check() {
-# cd "${srcdir}/${_pkgname}-${pkgver}"
-# make -j check
-#}
+
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
- make install
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir" make install
+ install -Dvm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}