summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIan Schoonover2018-11-03 13:16:09 -0700
committerIan Schoonover2018-11-03 13:16:09 -0700
commit2c904b11f91bf6dc83d03e160be697a4bffceef9 (patch)
tree0722c4bf8c4d3f0450cbf024bbe0b82bb2c47ba5 /PKGBUILD
downloadaur-libhunspell1.3.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df1370936207
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# $Id$
+# Maintainer: Ian Schoonover <schoonover DOT ian AT gmail DOT com>
+# Contributor: Andreas Radke <andyrtr@archlinux.org>
+# Contributor: Hussam Al-Tayeb <ht990332@gmail.com>
+
+pkgname=libhunspell1.3
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="Only the libraries provided by hunspell, the spell checker and morphological analyzer"
+arch=('i686' 'x86_64')
+url="http://hunspell.sourceforge.net/"
+license=('GPL' 'LGPL' 'MPL')
+depends=('gcc-libs' 'readline')
+optdepends=('perl: for ispellaff2myspell')
+source=(http://downloads.sourceforge.net/hunspell/hunspell-$pkgver.tar.gz)
+md5sums=('3121aaf3e13e5d88dfff13fb4a5f1ab8')
+
+build() {
+ cd "$srcdir/hunspell-$pkgver"
+ ./configure --prefix=/usr --disable-static \
+ --with-ui --with-readline --with-experimental
+ make
+}
+
+package() {
+ cd "$srcdir/hunspell-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ # delete everything but libraries
+ rm -rf ${pkgdir}/usr/{bin,include,share}
+ rm -rf ${pkgdir}/usr/lib/pkgconfig
+}
+