summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilken 'Akiko' Gottwalt2015-11-27 11:40:23 +0100
committerWilken 'Akiko' Gottwalt2015-11-27 11:40:23 +0100
commita20e86db24e73df08a3248565b88d4159d7ed430 (patch)
treef8287215ca4efa2fa94dc2587275c862537f5c3e /PKGBUILD
downloadaur-libomxil-component-mad.tar.gz
Initial commit of OpenMAX Bellagio MAD component build script including
64 bit fix.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9f69d1f0ca9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id$
+# Maintainer: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+# Contributor: Wilken 'Akiko' Gottwalt <akiko@mailbox.org>
+
+pkgname=libomxil-component-mad
+pkgver=0.1
+pkgrel=1
+pkgdesc="An opensource implementation of the OpenMAX Integration Layer API - MAD component"
+arch=('i686' 'x86_64')
+url="http://omxil.sourceforge.net"
+license=('LGPL')
+depends=('glibc')
+source=("http://downloads.sourceforge.net/project/omxil/components/libomxmad-${pkgver}.tar.gz")
+md5sums=('b2e398ef611b628ffc7c38a0accff2a6')
+
+prepare() {
+ cd ${srcdir}/libomxmad-${pkgver}
+
+ [ -f Makefile ] && make distclean
+ patch -Np0 -i ../../libomxmad_64bit.patch
+ autoreconf -fiv
+}
+
+build() {
+ cd ${srcdir}/libomxmad-${pkgver}
+
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ cd ${srcdir}/libomxmad-${pkgver}
+
+ make DESTDIR="${pkgdir}" install
+}